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Introduction
This is the documentation library for Springboard.
The Tutorials section contains general introductory material as well as task-based instruction.
The Reference section focuses more on individual features of the program. It includes lists of
commands, screen objects, and keyboard shortcuts.
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Copyright and legal information
This documentation describes version 1.03 of Springboard, copyright (c) 1998-2011 by Six Mile
Creek Systems LLC.
For more information, see the Springboard web site at:
http://6sys.com
Please send bug reports, feature suggestions, and general comments via:
http://6sys.com/contact
Use of Springboard is subject to acceptance of the following

PLAIN-ENGLISH LICENSE AGREEMENT
1. This software may be freely used for its intended purpose. You may not reverse-engineer it,
attempt to bypass or modify its registration code, or use parts of it in other software. You
may not redistribute it in any manner other than by linking to the Web page listed above.
2. The Author makes no warranty as to the correct operation of the program or its fitness for
any particular purpose.

Additional credits
Springboard contains the Graphics32 library, available at http://graphics32.org, and licensed
under the Mozilla Public License (MPL). All modifications made by Six Mile Creek Systems to the
GraphicEx library are available at http://6sys.com/Springboard/GR32_Mods.pas and
http://6sys.com/Springboard/GrayMap.pas.
Springboard contains the GraphicEx library, available at http://www.delphi-gems.com, and
licensed under the MPL. No modifications have been made by Six Mile Creek Systems.
The smooth-resizing algorithm is copyright (c) 1997, 1998 by Anders Melander,
anders@melander.dk, used with permission. Source code is available from Anders.
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Tutorials
Quick Start
To get started making storyboards with Springboard:

1. Select one of the drawing tools from the palette on the left.
2. Draw in the white frame box in the main window.
3. Type the text that goes with the frame in the text box at the bottom of the main window.
4. Use Edit > Add New Frame to move to the next frame.
To learn more:



explore this Help file



hold the mouse over buttons and controls to view quick descriptions in "tool tips"



look in the Status Bar at the bottom of the main window for additional explanations



press F1 while highlighting any menu item or when any dialog box is open to get more help.
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Layers
Drawing layers: Overview
Each frame in a Springboard file is made up of layers. If you have used other graphic editors,
such as Photoshop, Illustrator, Corel Draw, or Paint Shop Pro, you may already be familiar with
the layer model. If not, you can think of layers like pieces of paper that are held together in a
stack, with the following properties:



Layers on top obscure the ones underneath.



Layers can be moved around horizontally and vertically within the frame. Any part of a layer
that sticks out beyond the frame is clipped off (though you can see those parts with View >
Single Frame).



Layers can have transparency. Full transparency is like cutting a hole in the layer with
scissors; whatever is underneath will show through. Layers can also be partly transparent,
like a drawing on tracing paper.

The layers in the current frame are shown in the Layers palette:

There are two basic layer types: bitmap layers, that contain a grid of colored dots ("pixels"),
and vector layers, that contain a "vector object" that can be changed at any time, and which
converts itself to pixels whenever it is drawn on the screen.
Springboard's drawing tools work with either bitmap or vector layers, but not both. The "
natural-media" tools draw onto bitmap layers, while the vector tools create new vector objects
on their own layers.
Some quick tips and links on working with layers:



Layers can have colors assigned with them in various ways.



You can change the name of a layer, and its other properties, with the Layer Properties
dialog.



You can use the Layer > New command to add more global or local overlay layers. Make an
overlay in a different color for each kind of information you want to keep - e.g., for showing
object motion, areas that will require special effects, transitions, etc.



You can reorder and nest layers by dragging them in the Layers palette.
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If you need more room outside the frame to grab vector handles or to start drawing strokes,
use View > Single Frame.



To select one layer out of many, right-click in the frame where the layer has some content,
and choose Select Layer from the context menu.
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The Layers Palette
The Layers palette shows a list or tree of all the layers in the current frame:

Tools
A tool bar at the top of the Layers palette contains tools for the most common layer commands:
New Layer - creates a new global or local layer.
Delete Layer - deletes the selected layer.
Duplicate Layer - makes a complete copy of the selected layer.
Merge Down - merges the contents of the selected layer into the layer below it.
Merge Contained Layers - merges the contents of all layers nested under the selected
layer into the selected layer.

Columns
The columns shown for each layer in the Layers palette include:



The visibility indicator
. This is shown for visible layers. Clicking it makes the layer
invisible; clicking the same spot again makes an invisible layer visible.



The tree expand/collapse buttons



The layer icon, indicating the layer's type and whether it's global or local. Spot-color layers

. Use these to show and hide nested layers.

are indicated with a single-colored box

, full-color layers with intersecting color circles

and vector layers with a small representation of the contained vector type
Global layers' icons have a bold border around them



,

.

.

The layer name. The Base layer is in italics.

Nested layers are indented under their parent layers.

Using the mouse
Clicking on a layer selects it. All drawing affects the selected layer: natural-media tools draw
onto it, and vector tools create new vector layers under it. All Layer menu commands operate on
the current layer.
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Right-clicking a layer opens a context menu of commands that operate on that layer, similar to
the main Layers menu.
You can drag and drop layers in the Layers palette to reorder or nest them. The drag indicator
is a small triangle, sometimes acc ompanied by a line, that shows where a layer will end up in the
list if you release the mouse. In this example, the "street" layer is about to be moved so it comes
after the "sketch" layer:

And in this example, the "guy-fill" layer is about to be nested under the "street" layer:
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Local and global layers
The default Base and Camera layers are global layers, meaning they exist with the same name
and settings in all frames in the file. If you change any of the properties of a global layer, they
will change everywhere in the file.
Global layers are most useful for holding annotations that you want to make across all frames.
The default Camera layer is a good example: many frames will have camera movement, and it's
handy to be able to turn them all on or off together. Other examples of global layers you might
like to add to your projects are:



A Motion layer, for indicating the motion of objects within the scene rather than the motion of
the camera. If you make a global Motion layer with a different color than the Camera layer,
it's easy to tell object motion from camera motion.



An FX (or Effects) layer, for indicating areas of the frame that will need to be added or
modified specially in post.

You can also use local layers, that exist only in the current frame. You can use local layers in
addition to the Base layer to develop and organize the image for a given frame, without affecting
any other frames. For examples of local layers, see the nested layers section.
Global layers' icons are drawn with a black border around them in the Layers palette. For
example, in this Layers palette:

the Camera layer is global (and selected), the Space ship layer is local, and the Base layer is
global.
Note: The Base layer is always global. It cannot be made local, and it cannot be deleted. You
c an rename it and change its color, though. The Base layer's name appears in italics in the
Layers palette to indicate this special status.

To create a new global or local layer:
1. Do Layer > New
- or Right-click anywhere in the Layers palette and choose New from the context menu
- or Click the New Layer button

in the Layers palette.

2. You'll see the Layer Properties dialog. It looks like this:

Page 12

Springboard - version 1.01

3. Type a name for the new layer.
4. Select whether you'd like it to be Local or Global.
5. Change the color if you like, by clicking the arrow next to the color swatch and picking a
different color.
6. Press OK.

To change an existing layer from global to local:
1. Make sure the layer is selected in the Layers palette.
2. Do Layer > Properties
- or Right-click the layer in the Layers palette and choose Properties from the context menu
- or Double-click the layer in the Layers palette.
3. You'll see the Layer Properties dialog:

4. Click the Local radio button.
5. Click OK.
6. A confirmation dialog box will appear that looks like this:
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7. Click OK.
The layer you selected will be removed from all other frames in the file, and kept only in the
c urrent frame.

To change an existing layer from local to global:
8. Make sure the layer is selected in the Layers palette.
9. Do Layer > Properties
- or Right-click the layer in the Layers palette and choose Properties from the context menu.
- or Double-click the layer in the Layers palette.
10. You'll see the Layer Properties dialog:

11. Click the Global radio button.
12. Click OK.
The layer you selected will be created in all other frames in the file. Any image contents are not
duplicated, though; new layers in other frames are empty.
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Nested layers
We've said above that you can think of layers in a frame like pieces of paper in a stack. One
additional thing you can do with layers that you can't do with paper is to nest one layer within
another. We can say the nested layer is a child layer contained within the parent layer.
Nested layers are roughly analogous to gluing pieces of paper together so that when you move
the parent layer, all the nested child layers move with it. However, with layers, you can also
move child layers independently of the parent when that's convenient.
Opacity changes in a parent layer also affect all child layers. So, for example, nested layers can
be faded in or out together.
Let's look an example of a frame that uses nested layers:

This is a simple frame that has been constructed to allow for flexibility in placing the stick figure
("tjw"). Let's look at the layers:

The "face" layer contains the eyebrow, eye, and mouth.
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The "solid" layer is a white layer that's been drawn to white-out whatever's behind the face.

The "tjw" layer contains the rest of the stick figure's body. Both the "face" and the "solid" layers
are nested under it.
So, I can hide all three layers by simply clearing the "tjw" layer's visibility icon:

Note that the portion of the door that was obscured by the "solid" layer now shows through.
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After I turn "tjw" back on, I can turn off just the "face" layer by clearing its visibility icon:

Similarly, I can move the layers all together by selecting the "tjw" layer and moving it with the
Move Layer tool:

Note that the "solid" layer now obscures the right side of the door.
Or, I can select just the "face" layer and drag it independently:
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The end result:
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Layer colors
Color is managed slightly differently for each layer type.

Spot-color layers
Each spot-color layer has a single color associated with it.
Spot-color layers appear in the Layers palette as a shaded box in the associated color:

.

By default, drawing on a spot-color layer with a natural-media tool draws in this foreground
color, and erasing makes a layer transparent so that whatever's below it shows through. The
frame's background color will show through if no other layer is below.
You can set any natural-media tool to either draw in the foreground color or erase to the
background with the Foreground and Background buttons at the top of the Tools Palette:

This setting will stick to each tool.
The 'X' key toggles between Foreground and Background.
You can change a spot-color layer's color with the Layer > Properties command.

Full-color layers
Full-color layers contain both color information and transparency information at each pixel. You
can import a color picture into a full-color layer, then draw on it and/or mask it out - that is,
make parts of it transparent. You can also make a full-color layer from a spot-color layer using
Layer > Convert.
Full-color layers appear in the Layers palette as intersecting color circles:

.

You can draw on full-color layers in any color. The foreground color can be set for each
natural-media tool using the drop-down color menu that appears next to the Foreground button
when a full-color layer is selected:

Click this button:
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to see this color menu:
When you select the Background button with a natural-media tool, it simply draws in the frame
background color.
The exception is the Eraser tool. By default, the Eraser is set to Background. When you draw
with it on a full-color layer, the layer is made transparent. If you set the Eraser tool to
Foreground, it will make the layer opaque again where you drew.
Layer > Reset Transparency makes the entire layer opaque - so it effectively undoes any
erasing you've done with the Eraser tool. Layer > Matte In Transparency also makes the
entire layer opaque, using a slightly different technique.

Vector layers
New vectors created under a spot-color layer are created with the current Foreground or
Background setting. If the Foreground button is selected, the new vector will take on the color of
its containing spot-color layer. If the Background button is selected, the new vector will cut out
the containing spot-color layer, leaving it transparent.
Changing the color of a spot-color layer in the Layer > Properties dialog will also change the
colors of all Foreground-assigned vectors underneath that layer.

When the Edit Vector tool
is selected, the Foreground and Background buttons change the
color assignment of the edited vector. If the vector is under a full-color layer, the Foreground
color can be changed with the drop-down color menu; if the vector is under a spot-color layer,
the Foreground color cannot be changed.
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Fill layers
A fill layer is a spot-color layer in which you paint a "fill color", so that the interior of a sketched
object looks opaque.
For example, let's say you have drawn a background image in a frame's Base layer, using the
Pencil tool:

You want a character to walk into this frame. So, you create a new spot-color layer, and draw
the character at his final resting point:

The Layers palette now looks like this:

But you'd like this Guy's insides to be opaque, not transparent. You could do this by converting
the Guy layer to Full-color and then filling in precisely inside the pencil outlines without erasing
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them. But it's easier if you put the "fill" on a separate layer, you don't have to worry about
affecting the outline, and it's also easy to change the color later.
You'd also like the Fill layer to move with the outline layer, and the easiest way to do that is to
nest them together.
The Layer > Make Fill Layer command is a quick way to set up such a layer. After you run it,
the layer palette looks like this:

The Guy Fill layer has been created, and the Guy layer is nested under it. This is the easiest way
to arrange layers.
The Make Fill Layer command also tries to fill in the fill layer automatically. In the example, the
story frame now looks like this:

It has filled the Guy Fill layer with white inside the boundaries of all closed areas in the Guy
layer.
If Make Fill Layer doesn't fill the way you want, you can tweak the results in several ways:



If it didn't fill enough, undo one time (to undo the Deflate done by Make Fill Layer) and
draw more in the fill layer. The Quill Pen is often a useful tool for drawing fills.



If it filled too much, undo two times (to undo both the Deflate and the automatic fill) and
draw in the fill layer by hand. Or, remove areas from the fill layer using the Eraser or the
Quill Pen set to the background color.

When the fill is the way you want it, you can select the Move Layer tool and drag the Guy Fill
Layer to a new position:
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And you can now easily go on to record an animation of the character walking into the shot.

Tips for drawing objects that can be automatically filled
If you want to use the auto-fill feature, but it's not finding the edges of your drawings well, try
these tips:



Keep your object away from the edges of the layer.



Draw with darker lines.



Ensure that all parts of your drawing that you want to be opaque are entirely enclosed with
lines.
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The Story Tree
Use the View > Story Tree/Properties View command to see a hierarchical list of the
contents of your story:

You can create new sections of various types (Act, Scene, Shot, etc.) to organize your storyboard
frames by pressing the New Section button
Edit > Add New Section command.

at the top of the Story Tree view or with the

If you don't like the section names provided, you can use the File > Edit Story Structure
c ommand (or its tool button
in the Story Tree view) to change the names of sections, change
their nesting order, or change the way they're numbered.
When a sound clip is selected, one of the Edit Externally buttons

is enabled.

The item currently selected in the tree has its properties shown below the tree.
Properties for the entire story are shown when you select the "story root," which is the top
element in the story tree, with the open book icon
.
Sections that are split out are shown with an asterisk overlay

.
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Tasks
Animating the camera
While some dynamic media or stylistic choices may preclude re-framing a shot as it progresses,
most video and movie productions involve some kind of camera movement - zooms, pans,
dollies, cranes, etc.

Camera movement in a screenplay
Camera movement can be represented in a screenplay with phrases like "PAN RIGHT" or "ZOOM
IN" (conventionally all-uppercase). Whether or not you start with a screenplay before creating
storyboards, typing these phrases into Springboard's frame text box is a quick way to represent
camera moves, and can be particularly useful if you want to work with a printout of just the
frame text, without accompanying images.

A frame with a camera movement instruction in its frame text

Camera movement in a storyboard
The most common way to represent camera movement in a storyboard use graphical arrows and
boxes, with some loose conventions to indicate particular moves.
In general, there are two sets of conventions for representing camera moves: those that use a
single thick arrow set in three-dimensional or "story" space, and those that use frame boxes
in two-dimensional or "frame" space. For example:

Page 25

Springboard - version 1.01

Pan right using thick arrow and using frame boxes

Zoom in using thick arrow and using frame boxes
Springboard's thick arrow and Zoom Frame tools are designed to help represent these
conventions.
In general, the thick arrow approach is compact and suggestive: it indicates the direction the
camera is moving, but not exactly how far. The frame box approach is more precise, because it
shows exactly where the frame begins and ends, but it sometimes takes up more visual space.

Camera movement in an animatic
When you want to view an animatic of your production, you could simply cut between frames
and show camera movement with the same graphical symbols used in the static storyboard. But,
it's more direct to simulate the actual camera moves dynamically.
Springboard can automatically interpret Zoom Frame vectors in the Camera layer as camera
moves, so that the pan pictured above looks something like this when it's viewed in the Movie
View or exported to a movie file:

Pan right, shown dynamically in an animatic
See the Automatic Zoom feature for more details.

Productive ways to work with camera movement
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The alternatives described above can be used in different combinations to suit your personal
style or project requirements. Here we'll suggest two different approaches that you could choose
as starting points:
1. Use each technique successively as you refine your prodction.
In this approach, you would start by typing short phrases in the frame text area as you rough
out your frame drawings for a production (or for a particular sequence). Then, as the drawings
take shape, add thick arrows to get a more visual feel for the camera moves. Finally, replace the
thick arrows with Zoom Frames to express the move more precisely and show it dynamically in
animatics.
Note that you c an also mix thick arrows (or other symbols drawn freehand) with Zoom Frames.
If you hide a Zoom Frame vector, it will still be animated as long as "Animate camera" is still
checked for the frame, so you could get a precise and dynamic camera move in an animatic
while still showing a simple or customized graphic in your printed storyboards if you prefer.
2. Use Zoom Frames exclusively.
It may be simpler to use a Zoom Frame from the start and refine it successively rather than
successively refine text phrases to arrows to Zoom Frames. You may also find that working with
a Zoom Frame in place as you draw, and adjusting both the Zoom Frame and the drawing as you
refine a sequence, helps support your visual thinking process.
Springboard can support both of these approaches comfortably, and there's no need to make a
decision ahead of time.
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Automatic Zoom
Springboard's Automatic Zoom feature translates Zoom Frame vectors into camera movement in
animatics and when exporting a movie.

To use Automatic Zoom with a new file:
1. Draw your frame content.
2. Select the Camera layer in the Layers Palette.
3. Select the Zoom Frame tool, drag out a new vector, and position it where you want it.
4. View the resulting camera move with the Go > Play command.
The camera move starts at the beginning of the frame, and extends to the end of the frame,
using a simple linear interpolation. More options for controlling the start, duration, and
ease-in/ease-out of Automatic Zoom will come in a future version of Springboard.

To use Automatic Zoom with an old file:
For files created with a version of Springboard older than 0.7, Automatic Zoom is disabled by
default, so that existing animatics will not be changed without your permission. To turn on
Automatic Zoom in an older file:
1. Ensure View > Story Tree/Properties View is turned on, so you can see the Properties
palette.
2. Select the frame for which you want to activate Automatic Zoom.
3. Check the Animate camera box in the Frame Properties dialog.
4. Repeat steps 2 and 3 for each frame containing a Zoom Frame vector that you want to be
animated automatically.

To disable Automatic Zoom on new frames:
Newly-created frames (in old or new files) have the "Animate camera" box checked by default.
To prevent this:
1. View the Preferences dialog with Edit > Preferences.
2. Select the Camera tab.
3. Un-check Enable automatic camera moves for new frames.

To disable Automatic Zoom on a specific frame:
1. Ensure View > Story Tree/Properties View is turned on, so you can see the Properties
palette.
2. Select the frame for which you want to activate Automatic Zoom.
3. Un-check the Animate camera box in the Frame Properties dialog.

To disable Automatic Zoom globally:
1. View the Preferences dialog with Edit > Preferences.
2. Select the Camera tab.
3. Un-check Animate the camera to follow Zoom Frame vectors.
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Using an external graphics editor
At some point during your work on a storyboard image, you may find that you want to do
something that would be easy in your favorite dedicated bitmap graphics editor (like Photoshop,
Corel Draw, Paint Shop Pro, The GIMP, etc.) but difficult in Springboard. Just for these situations,
Springboard supports editing a bitmap layer in an external program. You can use the features
you're used to in your graphics editor while still benefiting from Springboard's storyboard
structure.
The steps in the process are:
1. Configure external editing in the Edit > Preferences dialog, on the Edit Images tab. Test
it with the Test button on that tab before continuing.
2. Select the layer you want to edit externally.
3. Do Layer > Edit Externally.
4. Edit the image in the external editor, and save it.
5. Return to Springboard. The frame will update automatically to show the changes to the layer.
6. When you are done, do Layer > Finish Editing Externally in Springboard to finish.

Troubleshooting External Editing


You cannot edit vector layers externally. You can Merge them to another bitmap layer and
then edit that bitmap layer externally.



If you get an error message like "A device attached to the system is not functioning" when
you try to edit an image using the Test button in the Preferences dialog, Windows may not
be configured correctly to edit the specified image type. Try changing the options in the
Preferences dialog - some applications are set up to do Open properly but not Edit, or have
Open and Edit set up properly for Windows Bitmap files but not Truevision Targa files. If
c hanging these options doesn't work, you can try specifying the command line directly in the
Preferences dialog by selecting the "With this command line:" radio button, browsing for the
program file, and adding any necessary command-line arguments. (This requires detailed
understanding of the way your graphics editor works.)



If you find that a spot-color layer looks black in an external application, this may be because
the layer uses transparency in a way that your graphics editor does not interpret correctly.
Try viewing and editing alpha channels instead of RGB channels (these are the terms for
Photoshop; the exact names may differ in other products).



Another option that may simplify working with transparency is to use Layer > Matte-In
Transparency to discard a layer's transparency information before editing that layer
externally. If transparency is important for that particular layer, this won't be helpful, but for
many layers, transparency isn't important. Note that Layer > Matte-In Transparency only
works on full-color layers, so you would have to change a spot-color to full-color first using
Layer > Convert To Full Color.
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Working with sound
Sound clips
Springboard stores sound in sound clips, which appear in the Story Tree with this icon:
A sound clip contains a single sound, like a sound effect, a voice-over, a dialogue track, or a
musical score. Sound clips play when the story is played in the Movie View, and are included
when you export a movie.
Sound clips can be placed in the story tree under the whole Story, under a Section, or under an
individual Frame. For example, in the Story Tree pictured below:

The "Voice-over" sound clip is placed under the Story, so it will play throughout the story. The
"Ambience" clip will play starting at the beginning of Scene 2. The "SFX door open" and
"Dialogue" clips both play simultaneously at the beginning of Frame 2.3.
Sound clips are numbered consecutively within their parent element, just so they can have
unique names.
Sound clips move with their parent story elements. In the previous example, if you increased the
duration of Frame 2.2 so that Frame 2.3 started later, the Dialogue clip would play later as well.
The Ambience clip would still start at the same time and last the same length.
When a sound clip is selected in the Story Tree, the Sound Clip Properties dialog is displayed in
the Properties panel. This dialog lets you change the title and offset of the sound clip, and see its
start time and duration.

Importing
You can import sounds from WAVE files into sound clips in a Springboard file using the File >
Import Sound command. Imported sounds are copied and saved in the story file.
Note: At present, only WAVE files containing uncompressed PCM data are supported.
You must convert compressed WAVE files or other sound files to this format before
importing, using an external audio editing program. The next version of Springboard
should support compressed WAVE files.

Exporting
Sound clips are mixed and included automatically in video files exported using the File > Export
AVI command.
Future versions of Springboard will allow more options for export formats and codecs; currently,
audio is always exported as 16-bit PCM at 22.050 kHz.
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Recording
You can record sound clips while viewing your animatic in the Movie View. Use the Show More
button

in the Movie View's tool bar to display the Record Timing and Record Sound

buttons
Record button

, set them appropriately as described in the Movie View topic, and press the
to record.

Recorded sound clips are attached to the element selected when you begin recording. If a frame
is selected and the Movie View continues playing into other frames, one sound clip is created for
each frame. If a section or story is selected, only one sound clip is created.

Microphone setup
Before you record audio, be sure to set up your sound source appropriately. The exact steps to
do this depend on your specific sound card, but you can often use the Windows Volume Control
control.

To set up for recording with Windows Volume Control:
1. Open Windows Volume Control. You can do this by double-clicking the speaker icon in the
Windows system tray, if there is one, or from the Start > Programs menu under
Accessories > Entertainment > Volume Control.
2. View the recording settings, by selecting the menu command Options > Properties,
selecting Recording, and pressing OK.
3. Select the source. Click the "Select" check box under the Microphone channel (or whichever
channel corresponds to the sound source you'd like to record).
4. Drag the Volume slider up to the top of its range.
Keep the Volume Control open while you record. If what you record sounds distorted when you
play it back, drag the Volume slider down until it sounds clean.

If you can't hear anything after you record sound:
1. Check that your microphone (or other sound source) is plugged into the right jack on your
sound card or computer. If the jacks are color-coded, the microphone jack will be pink.
2. Check for a mute switch or volume control on the microphone, especially on headset
microphones. Ensure the sound is not muted and volume is up.
3. Check the Windows Control Panel under "Sounds and Audio Devices" to ensure your default
recording device is set up and working properly.
4. Try recording with the Windows Sound Recorder, usually in the Windows Programs menu
under Accessories > Entertainment > Sound Recorder. If you can't record there, it's
probably a system problem and not a problem with Springboard.

Editing sound externally
You can use most sound editing software to edit sound clips directly from a story file. This can be
useful if you want to change your recorded sound clips in ways that aren't yet available in
Springboard. For more information, see Using an external sound editor.
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Using an external sound editor
While working on sound for a story, you may find that you want to edit a sound in a way that's
easy in your favorite dedicated sound editor (like Goldwave, Audacity, Audition/Cool Edit,
Soundbooth, etc.) but not in Springboard. Just for these situations, Springboard supports editing
a sound clip in an external program. You can use the features you're used to in your sound editor
while still benefiting from Springboard's storyboard structure.
The steps in the process are:
1. Configure external editing in the Edit > Preferences dialog, on the Edit Sounds tab. Test
it with the Test button on that tab before continuing.
2. Select the sound clip you want to edit externally in the Story Tree.
3. Do Edit > Edit Sound Externally, or choose Edit Sound Externally or Split And Edit from
the context menu, or press the
button in the Story Tree's tool bar.
4. Edit the sound in the external editor, and save it back to the same file.
5. Return to Springboard. The sound clip will update automatically to match the saved file.
When you play your story in the Movie View, you will hear the new sound.

Sound Clips And Split Files
When you are done editing a sound clip externally, you can choose Edit > Unify to merge your
sound back into the main story file if you like. Unlike editing images externally, you don't have
to do this - you can keep sound files split out if you like.
Also, unlike other split files, which are saved as Springboard story files (.sbd), split files
containing sound clips are saved as Windows WAVE files (.wav). This allows them to be edited by
any standard sound editing program.

Troubleshooting External Editing


If a sound clip hasn't yet been saved to its split file when you edit it externally, Springboard
alerts you with a dialog box and gives you a chance to save it.



If you get an error message like "A device attached to the system is not functioning" when
you try to edit a sound using Edit Sound Externally or using the Test button in the
Preferences dialog, Windows may not be configured correctly to edit the specified image type.
Try changing the options in the Preferences dialog - some applications are set up to do Open
properly but not Edit, or do not support Open or Edit. If changing these options doesn't work,
you can try specifying the command line directly in the Preferences dialog by selecting the
"With this command line:" radio button, browsing for the program file, and adding any
necessary command-line arguments. (This may require detailed understanding of the way
your sound editor works.)



Some sound editors, such as Audacity, take a "project" approach to editing a file. They will
open a sound clip's split file correctly, but when you save your changes, they will save them
to a different place - often a project file or folder near the split file. You may have to do
something different to get them to save back to the same .wav file. For example, in Audacity
you need to do File > Export, then confirm that you want to overwrite the original split file.

Page 33

Springboard - version 1.01

Working with large files
If you're storyboarding a 43-minute television episode or a two-hour feature film - or some even
longer project - there are a few things you should know to keep Springboard running smoothly.



Use sections. Use the Story Tree to put your frames in sections of various kinds - shots,
scenes, chapters, or whatever other kind of sections make sense to you (you can customize
the list of available section names with the Edit Structure dialog). This not only helps you
keep your story organized, it also helps Springboard use your computer's memory more
efficiently.



Use split files. You can store certain sections of your story in split files to accelerate saving only the files containing changed data are rewritten when you save the master file. The Movie
View also uses split files to decide when to pre-render movie effects, so splitting out scenes
of large files can help make your movies play more smoothly within a scene.



Keep your frame images small. If you need high resolution images for your storyboard
frames, you can use them. But, if your computer has trouble keeping up, you may want to
use smaller frame images and simply zoom in on them while you're drawing. For many
productions and storyboarding styles, 320 x 240-pixel frames (Springboard's default) are big
enough to contain all the essential information and still produce acceptable image quality.
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Working with split files
Springboard's split files can help improve performance with large stories.
When you save a Springboard file, the program must copy all the data for the entire story into
the file on disk. For large files, this can mean that it can take many seconds to save the file after
even a small change to just one frame.
To speed up saving small changes to large files, you can choose to split out sections from the
master file. These sections are then stored in their own files, in a folder stored next to the
master story file.
For example, let's say you have a story file called Goldilocks.sbd. if you split out each Scene
section, Springboard automatically creates the following files the next time you save:



Goldilocks.sbd - the master file.



Goldilocks.sbd_files - the split folder, c ontaining:



Scene 1.sbd, Scene 2.sbd, etc. - the split files.

The next time you change something in Scene 1 and save, Springboard saves only
Goldilocks.sbd (which is now very small) and Goldilocks.sbd_files\Scene1.sbd (which is
also relatively small, since it only contains the frames for Scene 1).

Managing split files
You can split files with Edit > Split Out and Edit > Split Every.
If you later want to unify all the split files back into the master file, you can do this with Edit >
Unify or Edit > Unify Every.
Changes to split files don't take effect on disk until the next File > Save.
You can split out any section, or even individual frames. The recommended practice is to split
out every scene, or whatever may correspond to a scene in your story.
Sections or frames that are split out are indicated with an asterisk
example, here is the Story Tree for a file with all its Shots split out:

in the Story Tree. For

Warnings
When using split files:
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Don't separate the split folder. Keep the split folder next to the master file; if you move
the master file, always move the split folder with it.



Don't touch files while they're open. In order to conserve memory, Springboard only
loads pieces of the file as it needs them. So, if you open a file in Springboard, then move it or
c hange it with another program while it's still open, Springboard may not be able to view
parts of the file or save your changes successfully. (This does not apply to sound clips, as
discussed in Using an external sound editor.)

Editing split files separately
Split files are stored as normal Springboard storyboard files. You may open them directly in
Springboard, as long as the master file is not open at the same time (remember, Don't touch
files while they're open).
This can be convenient if, for example, you want to send a small section of a story to someone
else to work on or evaluate - for example, just Scene 3:
1. Make sure Scene 3 is split out.
2. Find the split file "Scene 3.sbd" in the split folder, and e-mail it as an attachment.
3. The recipient can edit the split file normally, and make changes.
4. The recipient then sends the changed "Scene 3.sbd" file back to you.
5. Delete the original "Scene 3.sbd" file from the split folder and save the new one in its place.
The changes will now be visible in the master file the next time you open it.
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Customizing Springboard
Once you get accustomed to using Springboard, you may wish to change some of its defaults.

Preferences
The most obvious place to change defaults is in the Preferences dialog. This dialog contains
settings that affect all files edited using the current user account of the current computer.

The Defaults file
You can set defaults for every file created with Springboard's File > New command on a given
c omputer. These defaults are stored in a file that you can edit like any other Springboard file.

To create a Defaults file:
1. Open a Springboard file with the settings you like. Or, start with a new file by choosing File
> New.
2. Edit the file until it contains exactly what you want in a new file.
3. Do File > Save As, and browse to the folder where Springboard is installed (usually
"C:\Program Files\Springboard"). Save the file with the name "Defaults".
4. To test your new defaults, choose File > New. You should see an untitled duplicate of your
Defaults file.
You can edit this file at any time if you wish to change the defaults.

HTML Templates
You can edit the templates used for the File > Export to > HTML command. These files are
stored in the Templates subfolder in the folder where Springboard is installed (usually
"C:\Program Files\Springboard").
You should have basic familiarity with editing HTML files in order to customize the templates.
Graphical HTML editors may work, but for best results, you may need to use a text editor.
See the text file "Template format.txt" in the Templates folder for more information.
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Reference
Keyboard shortcuts
Shift Keys


Holding the Shift key down while manipulating a vector will constrain the vector in an
appropriate way:

o Text and Line vectors are constrained to 45-degree angles.
o Rectangle and Filled Rectangle vectors are constrained to squares.
o Ellipse and Filled Ellipse vectors' black (orientation) nodes are constrained to
45-degree angles, and their red (shape) nodes are constrained to circles.

o All Arrow vectors' black (endpoint) nodes are constrained to 45-degree angles. Their
red (curve) nodes are constrained to lie on a straight line.

o Zoom Frame vectors are not constrained to the story's aspect ratio.


Holding the Shift key down while resizing a layer will keep the aspect ratio constant.



Holding the Ctrl key down while manipulating a vector or moving a layer will snap the point
you're dragging to the borders and corners of the frame. While dragging a layer's pivot point,
the pivot point is snapped to the center of the layer.



Holding the Alt key down while resizing a layer or a Zoom Frame will resize around the
center point.

Function Keys
Key

Meaning

F1

Context-sensitive help if available; otherwise, Help > Search
for Help On...

F2

Play Movie

F3

Previous Layer

F4

Next Layer

F5

Edit Layer Externally

F6

Finish Editing Layer Externally

F7
F8

Add New Section (of last-used type)
Add New Frame

F9

Page Back

F10

Frame Back
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F11

Frame Forward

F12

Page Forward

Ctrl+F9

To Starting Frame

Ctrl+F12

To Last Frame

Other Shortcuts
Key

Meaning

[

Moves the heaviness slider to the left.

]

Moves the heaviness slider to the right.

E

Toggles the Eraser tool while drawing.

N

Selects the Pencil tool, if a drawing layer is selected.

Q

Selects the Quill Pen tool, if a drawing layer is selected.

R

In the Movie view and the Frame Animation view: Starts
recording.

T

Selects the Thin Pen tool, if a drawing layer is selected.

V

When a drawing layer is selected: Toggles the Move Layer
tool.
When a vector layer is selected: Toggles the Edit Vector tool.

X

Toggles between the foreground and background colors for
the current drawing tool.

Escape

When playing a movie or layer animation: Stops it.
When the Movie view is active but not playing: Closes it.
When the keyboard focus is not on the frame grid: Moves it
there.
When you're drawing a vector: Toggles back to the last-used
drawing tool.

Enter

In the Frame Animation view: Starts playing from the start
of the frame.
When you're editing vector text: Inserts a new line.
When you're drawing any other vector: Toggles back to the
last-used drawing tool.

Space

In the Frame Animation view: Starts playing from the poster
time.

Ctrl+=

Zoom In

Ctrl+-

Zoom Out

Ctrl+`

View Frame Animation
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Ctrl+Alt+0

Zoom Actual Size

Ctrl+0

Zoom To Fit Frame

Ctrl+1

View Single Frame

Ctrl+F

Edit > Search And Replace

Ctrl+L
Ctrl+W

Lock Frame Position
New Layer

Ctrl+Z

Undo

Ctrl+Shift+Z,
Ctrl+Y

Redo

Left, Right, Up, Nudge the layer by one pixel when the Move Layer or Edit
Down
Vector tools are active.
Shift+Left,
Shift+Right,
Shift+Up,
Shift+Down
Ctrl+Alt+Left

Nudge the layer by 20 pixels when the Move Layer or Edit
Vector tools are active.

View > Scroll Current Frame > Left

Ctrl+Alt+Right View > Scroll Current Frame > Right
Ctrl+Alt+Up

View > Scroll Current Frame > To Center (biases toward
the left)

Ctrl+Alt+Down View > Scroll Current Frame > To Center (biases toward
the right)
Ctrl+Alt+R

In the Movie View: Toggles Record Sound

Shift+Ctrl+Alt In the Movie View: Toggles Record Timing
+R
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Mouse & pen shortcuts


If you are using a Wacom-compatible pen with an eraser button, you can flip it over to
erase in bitmap layers. The Eraser tool is automatically selected, and the last tool you were
using is re-selected when you switch back to the pen tip.



Right-clicking on most parts of the program brings up a context menu of commands that
operate on that object. Right-clicking in the frame adds a Select Layer c ommand for each
layer that has content at the point clicked.



You can reorder and nest layers by dragging them in the Layers palette.



Clicking the current frame number on the main tool bar pops up a menu of adjacent
frames and sections, allowing you to jump quickly to a precise point in the story.



Double-clicking a layer in the Layers palette brings up the Layer Properties dialog.



Double-clicking the "frame handle" (the area immediately to the left of a frame, below
the frame number) is a shortcut to View > Zoom to Fit Frame.



Double-clicking a Zoom Frame vector reverses the direction of its arrows.



Double-clicking a time control selects the nearest digit group.



Triple-clicking a time control selects the entire content.



Clicking in the Frame Animation timeline moves to that time in the frame's animation.



Dragging a file from Windows Explorer into Springboard's main window opens that file.
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The Tools Palette
All graphics tools are selected in the Tools palette:
The Move Layer tool

The Edit Vector tool

The natural-media tools

The vector tools

You can also select drawing and erasing colors using the swatches at the top of the Tools Palette.

The Swatch Box
Below the Tools palette is a sample of the current tool, called the swatch box:

The swatch is drawn with tool weight increasing from left to right. Weight is defined differently
for each individual tool type; see the sections above to see how it applies to each of the
natural-media and vector tools.
Below the swatch box is the Tool Weight Slider, which shows the current weight for the
selected tool. You can change the tool weight either by dragging the slider knob left and right, or
by clicking in the swatch, or with the [ and ] keys.
The Tool Weight Slider becomes the Layer Opacity Slider when the Move Layer tool is
selected.

Page 42

Springboard - version 1.01

The Move Layer tool

The Move Layer tool
lets you move, resize, rotate, and shear the current bitmap layer. It is
not available for vector layers.
Drag inside the layer to move it:

Drag any of the handles to resize the layer:

Use Shift while resizing to constrain the aspect ratio and Alt to resize around the pivot point
instead of from the opposite corner.
Drag outside the layer to rotate it around its pivot point:
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When creating animation, it may matter whether a rotation is positive or negative - e.g., a
half-turn clockwise vs. a half-turn counter-clockwise. Drag the layer in the direction you need;
the angle is displayed in light blue next to the pivot point, with positive rotation
counter-clockwise.
You can rotate a layer multiple times by simply using the handle to "wind it up." Multiple
revolutions are displayed with an R for the count of complete revolutions, like "1R + 25" for a
full revolution plus 25, or 385. Use multiple revolutions to animate things like rolling balls or
wheels.
By default, the pivot point is located at the center of the layer. Drag the pivot point indicator to
move the pivot point:

The layer will then rotate and scale around the pivot point's new position:
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Hold down Ctrl while dragging one of the side nodes to shear or skew the layer:

To return a layer to its default size and position, use the Reset Layer Position command.
The V key toggles between the Move Layer tool and the last-used drawing tool.
You can use the arrow keys to nudge the layer by one pixel. Holding down the Shift key while
using the arrow keys nudges the layer by 20 pixels.
Changes made with the Move Layer tool take effect at the current frame's poster time. Use the
Frame Animation View to change the poster time and create animated frames.
While the Move Layer tool is selected, the Tool Weight Slider becomes the Layer Opacity
Slider.
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Layer Opacity
While the Move Layer tool is selected, the Tool Weight Slider becomes the Layer Opacity
Slider. This slider controls how opaque or transparent the current layer is.

When the slider is all the way to the right, the layer is fully opaque (the default). When it is all
the way to the left, the layer is completely transparent, or invisible.
You can animate a layer's opacity to have it fade in during a frame.
If layers are nested, child layers are affected by changes in their parent's opacity. So, for
example, nested layers can be faded in or out together.
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The Edit Vector tool

The Edit Vector tool

lets you modify a vector that you've created with one of the vector tools.

While the Edit Vector tool is selected, you can drag the vector's nodes to change its shape. Each
vector type has a different set of nodes that control its shape in different ways. For example, the
following images shows the nodes of an arrow vector:

When the cursor is near a node, it shows the standard arrow cursor
the node.
When the cursor is outside a node, it shows the drag cursor
move the entire vector.

, indicating you can drag

, indicating that dragging will

While you're dragging a vector node, holding down the Shift key constrains the vector in an
appropriate way. See each vector's section in Vector tools for more details.
The V key toggles between the Edit Vector tool and the last-used tool.
You can use the arrow keys to nudge the entire vector by one pixel. Holding down the Shift key
while using the arrow keys nudges the vector by 20 pixels.
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Natural-media tools
The natural-media tools simulate the following real-world drawing tools:

- Pencil; gets darker the harder you press

- Pencil eraser; erases a wider area the harder you press

- Steel nib or quill pen: gets larger the harder you press

- Fine-point marker or Rapidograph-style pen; always one pixel, doesn't vary with pressure.
If you're using a pressure-sensitive input device (like a tablet), simply press harder to get the
changes described, and use the heaviness slider in the Swatch Box to adjust the pressure
response.
If you are using a non-pressure sensitive device (like a mouse), you can use the heaviness slider
to change the "pressure" for each drawing stroke.
As discussed in Layer Colors, you can change the color each tool uses, and you can erase with
any of them. (The Eraser is the only tool that erases by default, but this can be changed as
described in that section.)
You can only draw on bitmap layers with the natural-media tools. What you draw becomes part
of the current bitmap layer as ink or graphite would go onto a piece of paper; to erase a mark
you've made, you must use an erasing tool.
In the current version of Springboard, Edit > Undo undoes all drawing strokes made to the
current layer since the tool was last changed.

Page 48

Springboard - version 1.01

Vector tools
When you draw with a vector tool, a new vector layer is created, nested under the current layer.
Then the Edit Vector tool is selected automatically so you can modify the new vector.
If you want to draw another new vector of the same type, you can switch back to the same tool
by pressing V, Escape, or Enter (except in the Text tool, which uses V and Enter to edit the text).
You can also move back to the parent bitmap layer by pressing F3 (the shortcut to Layer >
Previous).
Vector tools include:



The Line tool



The Text tool



The Rectangle tools



The Ellipse tools



The Arrow tool



The Solid and Outlined Arrow tools



The Zoom Frame tool
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Vector Tools
The Line tool
To create a Line vector, select the Line tool and drag from the first endpoint to the other
endpoint:

The Line vector has handles at either end that move the endpoints independently.
Holding the Shift key down while dragging a line endpoint node constrains the line to 45-degree
angles.
Like all vectors, you can also drag outside a Line vector while editing it to move the entire
vector.
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The Text tool
To create a Text vector, select the Text tool and click in the frame. A baseline (drawn in light
blue) is created for the first line of the first paragraph. You can then type text, and edit it with
the usual mouse gestures and keyboard keys:

The handles at the ends of the baseline move the endpoints independently, just like the Line
tool:

Holding the Shift key down while dragging a baseline end node constrains the baseline to
45-degree angles.
The Text Properties box appears while you're editing a Text vector:

Changes you make in the Text Properties box affect the current vector immediately.
The settings used for a new Text vector are copied from the last-edited Text vector. So, to make
a new Text vector like an existing one, select the existing layer, select the Edit Vector tool, and
then select the Text tool and click to create the new vector.
The cursor you see when the Text tool is selected reflects the last-used Alignment setting:
Left Alignment - the baseline will extend to the right of where you click.
Center Alignment - the baseline will be centered where you click.
Right Alignment - the baseline will extend to the left of where you click.
If the last-used Alignment is not what you want for the new Text vector, create the vector and
then change its Alignment using the Text Style dialog.
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The Rectangle tools
To create a Rectangle or Filled Rectangle vector, select the tool and drag from the upper-left
corner to the lower-right corner.

Rectangle and Filled Rectangle vectors have handles at the upper left and lower right that move
these corners.
Holding the Shift key down while dragging a rectangle constrains it to a square.
Rectangles are always drawn parallel to the edges of their parent layer.
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The Ellipse tools
To create an Ellipse or Filled Ellipse vector, select the tool and drag from the center of the ellipse
or circle to the widest radius:

An Ellipse's center is marked with a pair of light blue center lines. The gray node in the center
moves the circle (just as dragging outside the entire vector does); the other gray "orientation"
node sets the radius, and the red "shape" node sets the "minor radius" for the ellipse.
If the red node is never moved, the Ellipse will be a perfect circle.
Holding the Shift key down while dragging a gray orientation node constrains the ellipse to
45-degree angles.
Holding the Shift key down while dragging a red shape node constrains the vector to a circle.
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The Arrow tool
To create an Arrow vector, select the Arrow tool and drag from the back of the arrow to the tip of
the arrowhead:

The Arrow's nodes are:

Holding the Shift key down while dragging a gray endpoint node constrains the arrow to
45-degree angles.
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The Solid and Outlined Arrow tools
To create a Solid or Outlined Arrow vector, select the tool and drag from the back of the arrow to
the tip of the arrowhead:

The nodes are the same for both the Solid and Outlined arrow types:

Holding the Shift key down while dragging a gray endpoint node constrains the arrow to
45-degree angles.
Holding the Shift key down while dragging a red curvature node constrains the arrow to a
straight line.
The fill lines are drawn automatically in the Outlined Arrow; there are no controls for them.
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The Zoom Frame tool
To create a Zoom Frame vector, select the Zoom Frame tool and drag from the upper-left corner
of the inner zoom rectangle to the lower-right corner of the inner zoom rectangle:

The Zoom Frame tool creates two rectangles, and joins their corners with arrows. The outer
zoom rectangle is initially created outside the overall frame border, but you can shrink it by
dragging inside its corners or move it by dragging its center point (the center blue handle).
The blue handles are drawn at the corners and center of the "from" rectangle, and the red
handles are drawn at the corners and center of the "to" rectangle.
The arrows are automatically drawn so that they don't intersect any of the rectangles' lines;
there are no controls for them. Here are some examples of different ways the arrows can appear:

You can reverse the direction of the arrows by double-clicking anywhere, or by checking the
Reverse Direction box in the Zoom Frame Properties dialog. This also reverses the colors of
the handles, so that the blue handles are always on the "from" rectangle.

Automatic Zoom
By default, Zoom Frames under the Camera layer are interpreted as camera movements in
animatics. This is called Automatic Zoom, though it can also be used for other camera moves,
such as pans. A blue dot is drawn over any Zoom Frame that will be automatically animated:
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Zoom Frame is not under Camera - not animated

Zoom Frame is under Camera and will be animated
You can control the timing of the animated zoom frame with the Animation controls in the
Zoom Frame Properties dialog.

Sizing and snapping
The aspect ratio of a Zoom Frame rectangle is constrained by default to that of the story. (This is
set by the Default frame size in the Story Properties dialog.)
Holding the Shift key down while resizing allows you to change the aspect ratio, and displays
the resulting aspect ratio while you drag.
Holding the Control key down while dragging a node snaps it to other points in the frame and
snaps the aspect ratio to the story's default. You may get best results by using Shift whenever
you use Control.
Holding the Alt key down while resizing resizes around the center instead of the opposite corner.

Multiple Zoom Frames
You can use multiple Zoom Frame vectors in a single frame to assemble more complex camera
movements from single moves. This is particularly useful in combination with Automatic Zoom.
When you make a second Zoom Frame under a Camera layer, it is placed above the first in the
Layers palette, as usual with vectors. The first (lower) vector comes first in time order, followed
by the second (higher) vector. The vectors' icons are also changed to indicate this order:

The Zoom Frames are also linked so that the "to" rectangle in the first Zoom Frame (the one
with red node boxes) and the "from" rectangle in the second Zoom Frame (the one with blue
node boxes) move together:

Editing the first Zoom Frame (pan right)
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Editing the second Zoom Frame (zoom in)

Moved the "from" (blue) rectangle in the second Zoom Frame; the first Zoom Frame is linked.
If you reverse the order of the Zoom Frames with the Zoom Frame Properties dialog or by
double-clicking while editing one of them, the reversed order is shown in the Layers palette:

Note that Zoom Frames in other layers than the one designated in the Camera tab of the
Preferences dialog are not linked, do not have the blue markers in the Layers palette, and are
not used for Automatic Zoom.
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Views
Storyboard View
The Storyboard View is the default view when a new file is created. It gives you an overview of
the frames in your storyboard, and allows you to draw in storyboard frames while looking at the
adjacent frames.
Use the Zoom commands (View > Zoom In, Zoom Out, and Zoom Actual Size) to control
how many frames you view at once.
You can "focus in" on a single frame by switching to Single Frame View.
You can move around in the story in several ways:



by clicking on frames



with the Go menu commands, or their tool buttons or keyboard shortcuts



by clicking the large frame number on the right end of the tool bar



by dragging the slider at the top of the view



by selecting a frame in the Story Tree.

The View > Scroll Current Frame and View > Lock Frame Position commands can help you
see the context you want around the current frame.
The Storyboard View has one text box at its bottom called the frame text box. Text that you
type here is associated with the current frame. It will appear with the frame when the story is
printed. You can use this text for dialogue, action description, or any other kind of notes
associated with the frame.
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Single Frame View
The Single Frame View replaces the grid of frames in the storyboard frame view with a view of
the current frame only. This can be useful if you need more room outside the frame to grab
handles or to start drawing strokes.
You can also use it simply to reduce visual clutter, so you can concentrate on one frame at a
time.
You can enter Single Frame View with the View > Single Frame command, by double-clicking a
frame handle in the Storyboard View, with the View > Zoom to Fit Frame command, or by
clicking on the view's tab. Pressing Esc returns to Storyboard View.
The View > Scroll Current Frame and View > Lock Frame Position commands
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Frame Animation View

The Frame Animation View lets you animate layers within an individual frame.
You can open the Frame Animation View with the View > Frame Animation command, or by
opening the splitter bar above it [1].
The Frame Animation View contains a property tree [2] that shows the animated properties
of the current layer in the current frame. The two animated properties currently available are
the transform, which controls the layer's size, rotation, and position, and the layer opacity.
To the right of the property tree is a timeline [3] that shows keys where the animated
properties have been set. The value of a property is fixed at its keys; between the keys, the
property is interpolated - it varies smoothly and automatically from one key to the next.
You can move around in the timeline by clicking in it, or by dragging the timeline slider [4]
above it. The current time is called the poster time. The poster time is the time at which a
frame is rendered for use in all static displays, such as printing, exporting to sequential image
files, or in the story grid when the Frame Animation View is hidden. In the Movie View and
when exporting to AVI, the full frame animation is shown.
Note: In the unregistered version of Springboard, only animation in the first frame is visible in
the Movie View and when exporting to AVI. Subsequent frames are rendered at their start time.
The poster time's value is displayed on the main tool bar, between the zoom percent and the
frame number.
You can make a new key by moving to a time with no key, then pressing the Add Key
button in the tool bar [5] at the top of the view. Or, you can simply change the key's value e.g., by moving a layer with the Move Layer tool or changing its opacity with the Layer Opacity
slider.
You can delete a key by clicking it, then pressing the Delete Key button

, or by right-clicking
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it and choosing Delete Key from the context menu. Clicking the Delete Key button while no
keys are selected deletes all keys at the current time.
You can move keys left or right by dragging them.
You can play the frame's animation in real time using the Play
and Stop
buttons in the
tool bar. If you play through the end of the frame, the poster time is reset to its position when
you started playing. If you press Stop before the frame is finished playing, the poster time is set
to the time at which you pressed Stop. The Spacebar is the shortcut key for Play and Stop.
You can play the frame from beginning to end with the Play From Start
button in the tool
bar. When the end of the frame is reached, the poster time is reset to its position when you
started playing. The Enter key is the shortcut for Play From Start.
If the Render Transitions
button in the tool bar is highlighted (the default), transitions
between the previous and following frames will be rendered normally. Clicking the Render
Transitions button toggles this behavior. Transitions will always be rendered in the Movie View
and in Export Windows AVI, whether or not Render Transitions is highlighted.

Recording layer animation
You can use the Frame Animation view to record animation interactively. As you make changes
to a layer, Springboard can record your changes in real time as keys, so you can play back your
animation just as you recorded it. This is a very quick way to make simple layer animation.
Currently, you can record layer transformations (position, rotation, and scale) using the Move
Layer tool, and opacity using the Layer Opacity slider.

To record layer animation:
1. Open the Frame Animation View, and set the poster time where you want to begin recording.
2. Select the layer you want to animate in the Layers palette.
3. Select the Move Layer tool.
4. Press the Record button
pressed in

or press the R key. The Record button will turn red and stay

. Time will not advance until you begin to make a change to the layer.

5. Either drag the layer, its handles, or the Layer Opacity slider to animate the layer.
6. When you start dragging, all keys in the appropriate property will be deleted from the poster
time to the end of the frame.
7. Recording will stop when you release the mouse.
Your changes will be recorded and saved in keys for the appropriate property.
If you drag the mouse for longer than the current frame duration, the frame is extended to
include your entire drag.

To animate a layer with changes in more than one transformation component, you must record
the most difficult part first, then make the remaining key changes one at a time. For example, if
you want a layer to dance around and grow bigger at the same time, record the dancing motion
first, then go to the end of the frame and scale the layer up.
This restriction doesn't apply to opacity - opacity and transformations are fully independent, and
both can be recorded independently.
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Movie View

The Movie View lets you play your story in real time, as an animatic.
You can open the Movie View with the View > Movie View command, or with Go > Play, which
also starts the movie playing from the current frame.
You can play the movie in real-time, pause, and move around by frame with the transport
buttons at the bottom of the frame, which have their usual meanings.
You can drag the slider left and right to move quickly through the story. Any sound in the story
"scrubs," or plays in short loops, as you drag.
The current time point is displayed in the lower right. You can go to a particular point in time by
double-clicking on the time, editing it, and pressing the Tab key.

Recording frame timing
You can use the Movie view to record frame durations interactively. As you watch your movie
play, you can tell Springboard when to transition between frames. Springboard will time your
keystrokes and note down the duration of each frame and transition, so that when you play or
export your movie again, the timing will match.

To record frame timing:
1. Ensure the Movie View is open, and set to the frame where you want to begin. (The timing
for frames before this one will be left as they are.)
2. Press the Record button
pressed in

or press the R key. The Record button will turn red and stay

and the time will begin to advance.

3. Press the Frame Forward button

or the Right Arrow key when you want the frame to
Page 64

Springboard - version 1.01

advance. Release the button or key quickly.
4. To stop recording, press the Stop button or the Escape key. Recording will also stop when
you advance past the last frame.
Your timing will be recorded and saved in the frame durations.

Transitions you record in this way will be "cuts" - the frames will not overlap.

Smooth frame transitions
You can also record smooth "fade" transitions between two frames, so two consecutive frames
overlap in time.

To fade between two frames:
Hold down the Right Arrow key or Frame Forward button
for the duration of the
transition; let the key up when the transition should be complete.
You must hold down the key or button for at least 0.3 seconds in order to record a fade
transition. If you release it quickly, the transition will be recorded as a cut.

You can fine-tune both frame durations and frame overlap by editing the values directly for each
frame in the Frame Properties dialog.

Advanced controls
The Show More button

in the Movie View's tool bar reveals the advanced controls:



Press the Lock button
to keep the current frame in the main story view synchronized
with the current frame in the Movie view. When the Movie View plays or when you use its
transport buttons, the main story view will move along in sync. This can make it easier to
anticipate timing, because you can read dialogue, direction, or other frame text, and you can
look ahead to the next frame.



If Lock is not down, the Rewind On Stop button
controls whether the Movie View will
go back to the main story's current frame when playback stops. This can be useful if you
want to play the same sequence repeatedly.



The Border Color button
sets the color that surrounds the movie frame (which can help
you to see your movie without anything distracting around it).



The Matte Color button
sets the color used for fade-outs and around the borders of
frames that don't have the default aspect ratio.



The Zoom buttons
set the magnification for the movie view. They have no
effect on the main view, or on the size of the exported movie.



The Record Timing and Record Sound buttons
recording.

toggle these two types of

Recording Sound
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To record narration along with frame timing, set up your microphone as described in Working
with sound, and ensure the Record Sound button
is down. Then follow the instructions
above under Recording frame timing, while speaking into the microphone. When you stop
recording, sound clips will be created and inserted into the Story Tree.
If you begin recording with a frame selected in the Story Tree, new sound clips will be attached
to each frame played as you record. If you begin recording with a section selected in the Story
Tree, a single sound clip will be attached to that section.
To record sound without changing existing frame timing, ensure the Record Sound button is
down and the Record Timing button
is up. Frames will play and transition at their normal
rate, and your recorded sound will be placed in sound clips as above.
Existing sound clips play during recording if Record Timing is off. If Record Timing is on,
sound clips that are attached to the story root are played normally; sound clips attached to
frames are played when those frames are triggered, but will have their beginnings cut off due to
the
If neither Record Timing nor Record Sound is on, the Record button

is disabled.
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Commands
Menu index
This section lists the commands grouped by their location on the main menu.

File


File > New



File > Open



File > Save



File > Save As



File > Save Numbered Backup



File > Move



File > Edit Story Structure



File > Print



File > Import Image



File > Import Sound



File > Export To > Windows AVI



File > Export To > HTML



File > Export To > Sequential Bitmap



File > Export To > Sequential GIF



File > Export To > Sequential JPEG



File > Export To > Sequential Targa



File > Export Again



File > Close



File > Revert



File > (most-recently-used files)



File > Exit

Edit


Edit > Undo
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Edit > Redo



Edit > Clear Undo Information



Edit > Cut



Edit > Copy



Edit > Paste



Edit > Delete



Edit > Add New Frame



Edit > Add New Section



Edit > Split Out/Unify



Edit > Split Every



Edit > Unify Every



Edit > Edit Sound Externally



Edit > Split And Edit



Edit > Search And Replace



Edit > Preferences

Go


Go > To Starting Frame



Go > Page Back



Go > Frame Back



Go > Frame Forward



Go > Page Forward



Go > To Last Frame



Go > Play

Image


Image > Image Size



Image > Canvas Size



Image > Set Background Color



Image > Mirror Horizontally



Image > Clear
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Layer


Layer > Previous



Layer > Next



Layer > New



Layer > Duplicate



Layer > Properties



Layer > Reset Position



Layer > Bake Position



Layer > Mirror Horizontally



Layer > Scale to Fit Frame



Layer > Convert to Full Color/Spot Color



Layer > Merge Down



Layer > Merge Contained Layers



Layer > Deflate to Fit Content



Layer > Inflate to Fit Frame



Layer > Reset Transparency



Layer > Matte-In Transparency



Layer > Matte-Out Color



Layer > Clear



Layer > Edit Externally



Layer > Finish Editing Externally

View


View > Zoom In



View > Zoom Out



View > Zoom Actual Size



View > Zoom To Fit Frame



View > Single Frame



View > Frame Animation



View > Scroll Current Frame > Left/Right/To Center



View > Lock Frame Position
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View > Tool Palettes On > Left / Right



View > Movie View



View > Story Tree/Properties View
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Add New Frame
Edit > Add New Frame inserts a new frame after the current one.
To insert a frame before the first frame of the file, use Add New Frame and then drag the new
frame above the first frame in the Story Tree.
The default frame size is 320 x 240 pixels; you can change this in the Story Properties dialog.
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Bake Layer Position
Layer > Bake Position keeps the current contents of a layer where they are, but normalizes
the layer's scale and position so it is neither rotated nor scaled. It also fits the border of the layer
around its contents, like Layer > Deflate To Fit Content.
This is particularly useful to reduce the resolution of a layer's image. If you import a very large
image, say 4000 x 3000 pixels, into a 640 x 480 frame, Springboard will scale it down. It will
look fine, but the extra pixels don't contribute to the appearance and may consume a lot of
space in your file. Springboard saves the extra information because you want to enlarge the
layer later to see more detail. But, if you don't need to enlarge the layer, you can Bake it to
resample it at the frame resolution and save space.
You can also use Bake to increase resolution, if you've enlarged a very small image. It will
smooth out the large pixels, which may improve the layer's appearance. And, it will give you
more pixels to work with if you're drawing over it, either in Springboard or in an external editor.
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Clear Undo Information
The Undo and Redo commands store data that is used to undo and redo the effects of other
actions. This data takes up memory, and the longer you use Springboard, the more memory it
takes up.
If you see symptoms that you are running out of memory - e.g., the computer is running slowly,
or Windows shows a message saying it has increased the size of its virtual memory pool, or Task
Manager or another tool says the Springboard program is using more memory than your
computer has - you can use Edit > Clear Undo Information to discard all that data and free up
memory.
After clearing the undo information, you can no longer undo the actions you've done. New
actions you take will continue to be added to the undo list normally.
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Convert Layer
This command converts a bitmap layer between spot-color and full-color modes. Its full name
matches the current layer type.
Layer > Convert to Full Color converts a spot-color layer to full-color. The resulting layer is
filled with the spot color, and is opaque where the spot-color layer was drawn on and transparent
where it was blank.
If you want to convert a spot-color to a full-color layer that's entirely opaque, that goes from the
frame background color to the spot color instead of from transparent to opaque, follow this
c ommand with Layer > Matte In Transparency.
Layer > Convert to Gray Spot Color converts a full-color layer to a gray spot-color layer. The
resulting layer is transparent wherever the full-color layer was white or transparent, and opaque
black wherever the full-color layer was dark.
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Deflate Layer To Fit Content
Layer > Deflate to Fit Content discards the transparent areas of a drawing layer and shrinks
down its border so it only includes a rectangular region around what's been drawn. Use it to
reduce the layer for easier resizing and rotation.
Note that only areas that are 100% transparent are trimmed away from the layer. So, if the
layer's border appears to enclose empty space, there may be pixels that appear transparent but
are just slightly opaque. Running over the edges with the Eraser tool again may help ensure that
the areas you intend to erase are completely transparent.
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Duplicate Layer
Layer > Duplicate duplicates the current layer's contents onto a new local layer.
The original layer still exists with the same contents, and you can edit both layers separately.
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Edit Layer Externally
The Layer > Edit Externally command saves the current bitmap layer to a file, then opens that
file in the external graphics editing program of your choice. The current frame is then locked
from modification until you do Layer > Finish Editing Externally.
To specify the external editor to use, the mechanism used to start it up, and the type of file used
to open the layer in the external graphic editor, see the Edit Images tab of the Edit >
Preferences dialog.

See also: Using an external graphics editor
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Edit Sound Externally
Edit Sound Externally opens the currently-selected sound clip in your preferred external editor.
It's only enabled if the current selection in the Story Tree is a sound clip that is already split. If
it's a sound clip that is unified (not split), the Split And Edit command is enabled instead.
If you haven't saved the file since the sound was split, you will be prompted to do so. This
ensures that the split file will exist.
The split file is then loaded in the external editor. Once it's open, you can edit it in the external
editor. After you save it, the new saved version will automatically be used when you return to
the Springboard file.
See also Using an external sound editor.
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Export To
Use the File > Export To commands to export to a series of numbered GIF, JPEG, Targa, or BMP
files, to an HTML page, to a Wave audio file, or to a Windows AVI file.
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Finish Editing Layer Externally
After you have done Layer > Edit Externally on a layer, the frame that contains that layer is
locked for changes and updates automatically whenever you switch back to Springboard from the
external editor.
To finish editing externally, do Layer > Finish Editing Externally. This reloads the temporary
file that you were editing externally, deletes it, and unlocks the frame.
You must finish all external editing operations before closing a file.
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Import Image
File > Import Image lets you select one or more graphic image files and bring them into the
Springboard story file.
Supported import formats include Windows Bitmap (BMP), Encapsulated PostScript (EPS), GIF,
JPEG, Photoshop (PSD), PNG, Targa (TGA), TIFF, Windows Metafile (WMF), and Enhanced
Metafile (EMF). Alpha channels are supported in BMP, Photoshop, PNG, Targa, TIFF, and
Metafiles; a single level of transparency is supported in GIF files.
You can select the files to import in the usual file-selection dialog.
Springboard then shows you the files in a list:

The files are in alphabetic order by default, but you may drag them up or down to reorder them.
You may also choose one of the radio buttons below the list to determine how the new images
will be inserted:



Layers - the images are placed as new consecutive layers in the current frame, and each new
layer is named after its source file



Frames, in Base layers - a new frame is created for each image, the images are placed in the
new frames' Base layers, and the Base layers for those frames are converted to color if
necessary



Frames, in new layers... - a new frame is created for each image, the images are placed in
new layers in those frames, and each new layer is named after its source file.

When you press OK, Springboard checks the size of the input files. If some are larger than the
frame size, it presents the Reduce Imported Images dialog:
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Resample is generally the right choice for background images; it discards the resolution that is
not needed to display the image at the frame size. But, you can choose Scale To Frame to keep
the full resolution internally if you plan to enlarge or crop the imported images later, or Import
Full-Size if you want to import frames or layers at the full size of the image files.
Images are imported as full-color layers. Once imported, you can optionally convert them to
spot-color layers with the Image > Convert command.
If you chose Scale to Frame, you can later restore the imported layers to their original scale
with Layer > Reset Position.
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Import Sound
File > Import Sound lets you select a sound file and copy its contents into the Springboard
story file as a sound clip.
Supported import formats include only Windows WAVE files containing uncompressed PCM data.
The next version of Springboard should support compressed formats as well.
You can select the file to import in the usual Windows file-selection dialog. You can press the
black triangle button

to play the selected sound file.

Imported files are placed under the currently-selected element in the Story Tree.
See also Working with sound.
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Inflate Layer To Fit Frame
Layer > Inflate to Fit Frame adds transparent regions around the edges of the current drawing
layer to expand it to fill the entire frame.
Use this command if you have a layer that's been deflated, scaled down, or imported from an
external file, and you want to draw new content on that layer in an area outside the layer's
c urrent border.
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Lock Frame Position
When View > Lock Frame Position is checked, Springboard will try to keep whichever frame is
c urrently selected in the same place in the frame grid.
For example, if your screen looks like this, with frame 1c selected in the lower left:

Selecting View > Lock Frame Position and then Go > Frame Forward will scroll the window
so frame 1d appears in the lower left:

You might want to use this command in situations like these:
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You're drawing a storyboard in sequence, one frame at a time. In this case, lock the current
frame in the last spot in the grid, so you can see everything that came before it as you draw.



You're evaluating the flow of your story, and you want to make notes about shot durations or
transitions while seeing as much context as possible for the current frame. In this case, lock
the current frame in the center of the grid (perhaps with View > Scroll Current Frame >
To Center).



You're recording audio narration in the Movie View, and you want to see what's coming next
to help time your delivery.

Lock Frame Position is automatically turned off when you change frames with the mouse, and
when you close a file.
Using the View > Scroll Current Frame commands while Lock Frame Position is active
leaves the frame position locked, but changes it as indicated by the Scroll command.

Page 86

Springboard - version 1.01

Make Fill Layer
Layer > Make Fill Layer creates a new spot-color layer whose color is the same as the current
frame's background, and inserts that layer as the parent of the current layer (which we will call
the "outline layer" here).
It then attempts to make the fill layer opaque only under the outline layer's content. It does this
using a "flood fill" of transparency, starting from the upper-left corner of the frame and stopping
when it hits content in the outline layer.
It then deflates the fill layer, so it's easier to grab and move.
All three of these actions - inserting the new layer, auto-filling, and deflating - are undoable.
See Fill Layers for why you'd want this command and how to use it.
Make Fill Layer is only enabled when the current layer is a local bitmap layer.
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Matte In Layer Transparency
Layer > Matte In Transparency works similarly to Layer > Reset Transparency, in that it
also makes an entire full-color layer opaque. But, it tries to preserve the current appearance of
the layer, by essentially painting the transparent areas with the frame's background color.
This is particularly useful when you've drawn with the drawing tools on a color layer (or you've
converted a spot-color layer to a full-color layer), and you want to start working with
transparency.
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Merge Contained Layers
Layer > Merge Contained Layers works like Layer > Merge Layer Down, but combines all
layers nested under the selected layer into the selected layer itself.
If you're sure an entire subtree of layers is positioned in the right place, this saves memory and
file space, and also simplifies your layer set.
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Merge Layer Down
Layer > Merge Down "stamps" the content of a layer down to the layer below it and discards
the old layer.
If you're sure a layer is positioned in the right place, this saves memory and file space, and also
simplifies your layer set.
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Move File
Use File > Move to rename a file or move it to a new folder.
This command works just like File > Save As, but it removes the original file after successful
c ompletion.
It also moves the split folder correctly, if any.
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Print
The File > Print command lets you lay out your storyboard as you wish, shows a preview of how
it will look when printed, and lets you select a printer, change its settings, and print. You can
also load print settings from other files you've made.
[More information to come.]
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Play Movie
Go > Play shows the Movie View, and begins playback from the current frame.
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Reset Layer Position
Layer > Reset Position undoes any adjustment that's been done to a layer's position, whether
through the Move Layer tool or other layer commands.
It returns drawing layers to their full resolution (1:1 scale), undoes any rotation, and moves
them to the upper-left corner of the frame.
If a layer is nested under another layer, its scale, position, and rotation will be reset to the same
as its parent layer's, which may not be aligned with the frame.

Page 94

Springboard - version 1.01

Reset Transparency
Layer > Reset Transparency makes a full-color layer completely opaque, by revealing all
areas of it that have been made transparent. It effectively undoes any erasing you've done with
the Eraser tool.
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Save Numbered Backup
Use File > Save Numbered Backup to make a backup of your file in the same folder.
For instance, if your file is called "myfile.sbd", this command will save a copy of the file in
"myfile_1.sbd". The next time you save a backup, it will be called "myfile_2.sbd", etc.
You can delete older backups whenever you wish, and newer ones will still continue following the
highest-numbered backup file that remains in the same folder as your main file.
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Scale Layer To Fit Frame
Layer > Scale To Fit Frame reduces or enlarges the current bitmap layer so it will fit in the
c urrent frame.
The current aspect ratio and rotation of the layer is preserved, so if the frame's aspect ratio is
different, the layer will only be resized until it fills the frame in one dimension.

To make a layer exactly fill the frame:
1. Do Layer > Reset Position.
2. Do Layer > Scale To Fit Frame.
3. Holding the Ctrl key down, drag the corners of the layer until they snap to the corners of the
frame.
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Scroll Current Frame
The View > Scroll Current Frame commands scroll the story grid so that the current frame
stays selected, but moves to a different cell in the grid. You can use them to control which
frames you can see on either side of the current frame.
For example, start with the storyboard shown here:

Scroll Current Frame > Left moves the current frame to the left in the grid, by moving forward
in the story:

Scroll Current Frame > Right moves the c urrent frame to the right in the grid, by moving
backward in the story:
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If either of these commands can't scroll the current frame any farther in the indicated direction,
it will move to the next frame in that direction.
Scroll Current Frame > To Center puts the current frame in the center of the grid:

If frames vary widely in size, Scroll Current Frame > To Center may not choose the exact
c enter position. If the grid contains an even number of frames, the current frame will move to
the position to the right of the center.
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Split And Edit
The Split And Edit command lets you split a selected sound clip, and then edit it externally, in a
single step.
It is otherwise identical to selecting Split Out on the sound clip and then Edit Sound
Externally.
See also Using an external sound editor.
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Split Every
Edit > Split Every splits out every object in the file that are the same type as the current
selection.
For instance, if you click on a Shot in the Story Tree:

the Edit menu item now reads "Split Every Shot." If you now choose Edit > Split Every Shot,
all Shots in the story are split:

Split Every has no effect on objects that are already split out.
The new split files are not actually saved until the next File > Save.
The reverse of Split Every is Unify Every.
This command also appears on the Story Tree's context menu.
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Split Out/Unify
Edit > Split Out makes the currently-selected frame or section into a split file.
This command is a toggle; when the currently-selected item is already split, it's labeled Unify
and stores the current selection in the master file.
Split files are not actually saved or removed until the next File > Save.
This command also appears as a button
context menu.

on the Story Tree's tool bar and in the Story Tree's
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Undo and Redo
Edit > Undo reverses the last change made to the story.
Edit > Redo restores the last change undone. When you make a new change, Redo is no longer
available.
Undo and Redo are currently available for:



Individual strokes made with one of the Natural-media tools.



Deleting objects from the Story Tree and the Layers Palette.



Pasting all kinds of object from the clipboard.



Dragging objects in the Story Tree and Layers Palette, and changing layer visibility in the
Layers Palette.



Changes made to objects in all of the Properties dialogs.



Add Key and Delete Key commands in the Frame Animation View.



Dragging keys in the timeline in the Frame Animation View.



Changes made with the Move Layer tool, including recording.



Changes to layer opacity, including recording.



All Image menu commands.



These Layer menu commands: New, Duplicate, Properties, Reset Position, Mirror
Horizontally, Scale To Fit Frame, Convert Layer, Merge Down, Merge Contained
Layers, Deflate to Fit Content, Inflate to Fit Frame, Make Fill Layer, Clear.



Frame property changes - duration, overlap, and Animate Camera.



Changes to frame text, including those made with Search And Replace.



Changes to text vector text, including those made by pasting.



Splitting and unifying objects.



Importing and recording sounds.



Recording frame timing.

When you make a change that is not yet undo-able, Undo is no longer available. That is, you can
only undo the most recent changes that are undo-able.
Saving the information required to undo all your changes requires memory. If Springboard uses
up too much memory on undo information, you may want to Clear Undo Information.
The shortcut key for Undo is Ctrl+Z. The shortcuts for Redo are Ctrl+Shift+Z and Ctrl+Y.

Page 103

Springboard - version 1.01

Unify Every
Edit > Unify Every is the reverse of Edit > Split Every - it unifies all sections or frames that
are the same type as the current selection.
It has no effect on objects that are not split out.
The split files are not actually removed until the next File > Save.
This command also appears on the Story Tree's context menu.

Page 104

Springboard - version 1.01

View Frame Animation
View > Frame Animation switches to the Frame Animation View.
The tool button for View > Frame Animation is:
Its shortcut is Ctrl+`. You can exit back to the Single Frame View by pressing Esc.
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View Movie View
View > Movie View turns the Movie View on or off.
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View Single Frame
View > Single Frame activates Single Frame View.
Its shortcut is Ctrl+1, or double-clicking the "frame handle" at the left of a frame. You can return
to the Storyboard View by pressing Esc.
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View Story Tree/Properties View
View > Story Tree/Properties View shows or hides the Story Tree, as well as the Properties
dialog below it.
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Dialogs
Export Windows AVI
File > Export To > Windows AVI shows the standard Export To dialog to find a file name,
followed by the Export Windows AVI Options dialog:

You can change the Frame rate to use for the exported movie with the drop-down box, or revert
to the story's default frame rate with the Default Rate button.
The Video Options button brings up the Windows standard Video Compression dialog, letting
you choose from all the video compressors available on your computer and customize their
options. Springboard tries to select a compressor and compression settings that will work well for
you, but for optimum results you may need to experiment.
You can use the standard Resizing options to create an AVI file with a different size than your
story's default size. An AVI file must have a single consistent size throughout, so if your frames
are different sizes, these settings will control how they are fit into the AVI file's frame size.
You may need to select the Color reduction options to work properly with your chosen video
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c ompressor. Using no color reduction is usually appropriate; if color reduction is required by a
c ompressor, Springboard attempts to turn it on automatically, but you may need to experiment.
You can select the Timecode burn-in options to show the current story time in the lower right
corner of every frame of the AVI file. The Opacity slider adjusts the transparency of the gray
rectangle behind the timecode.
Sound clips in your story will automatically be mixed down into the output AVI file.
If you check Open when done, the AVI file will be opened and played in the default movie
player registered on your computer.
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Export HTML
File > Export To > HTML shows the standard Export To dialog to find a file name, followed by
the Export HTML Options dialog:

The Export to file box shows the folder and name for the main file; other files will be created in
the same folder, as needed.
Choose a template from the list provided to determine how your Web page will look. Notes on
customizing these templates and creating new ones are in the text file Templates\Template
Format.txt, in the Springboard install directory.
The HTML title is taken from the story title set in the Story Properties dialog.
file name.

It defaults to the

You can use the standard Resizing options to resize all your frames to a given target size. If
you do not check the Resize to fit in box, all frames will be saved at their current resolution.
Color reduction settings are used where the template uses GIF files. You can decrease the
colors further than the default to save space.
JPEG compression settings are used where the template uses JPEG files. You can decrease the
quality setting to save space.
If you check Open in default browser when done, the HTML file will be opened in the default
Web browser registered on your computer.
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Export To
The File > Export To menu lets you export to a number of sequential file formats, including
Windows Bitmap (BMP), JPEG, GIF, and Targa.
(more details to come)
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Export Again
If you've exported using one of the File > Export commands once already with a given story
file, you can use File > Export Again to export to the same file type, over the same file name,
with the same settings.

Page 114

Springboard - version 1.01

Preferences Dialog
The Preferences dialog contains tabs for various collections of preferences that affect the entire
program.
These settings affect all files edited in the current user account of the current computer. They are
not saved in files, so they will typically have different values if a Springboard file is opened by
another user on a different account or computer.
All changes in all tabs take effect when the OK button is pressed, and Cancel reverts all changes
in any tab.

Tabs include:



Edit Images



Edit Sounds



Display



Units



Camera
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Preferences - Edit Images tab

The Edit Images tab of the Preferences dialog contains settings that relate to editing graphics in
another graphics editor, like Photoshop, Corel Draw, etc. See "Using an external graphics editor"
for an overview of this process.
You can test these settings with the Test button. If a file is open in Springboard, the current
frame will be sent to the external editor; if no frame image is available, a sample image is sent.

Run which external editor
The "Run which external image editor" box specifies how Springboard should find the external
editor. Most graphics editors register themselves with Windows as the default editor for the file
types they support. Windows has two built-in ways an application can register itself to handle a
given file type: Open and Edit. These work the same, but typically the Open verb is used for
applications that are mainly quick viewers, and Edit is used by applications that can modify a
file.
So, normally, your external graphics editor should register itself with Windows under the Edit
verb, and Springboard will work correctly without any changes in this dialog box.
If it does not work correctly - if you get an error message, or if the image loads in the wrong
program - you can try the other verb (Open vs. Edit), or you can choose "With this command
line:" and click the button at the right of the edit box to browse for the program you want to run.
This should work with most graphic editors; unusual ones may also require extra symbols on this
line called "command line arguments." This information should be provided in the documentation
for your external program.

Format for external files
The "Format for external files" box specifies which graphics file format Springboard should use to
send the image to the external program.
Any image editor should support the Windows Bitmap format. If your external editor opens the
file in a strange way - for instance, if it discards transparency information - you may want to try
the Truevision Targa format instead; if your external editor supports it, it may be more reliable.
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Sample settings
Here are some settings that have been tested with various external editors:
Photoshop: "Edit" and "Targa" produce good results, with a default Photoshop installation.
Windows Paint: "Edit" and "Windows Bitmap" work with most Windows installations, assuming
no other application has redefined the Edit verb.
(If you have settings that work with another editor, please send them to Six Mile Creek Systems
for inclusion in this page, at support@6sys.com.)

See also: Using an external graphics editor
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Preferences - Edit Sounds tab

The Edit Sounds tab of the Preferences dialog contains settings that relate to editing sounds in a
dedicated sound editor, like Audacity, Goldwave, Audition/Cool Edit, Soundbooth, etc. See "Using
an external sound editor" for an overview of this process.
You can test these settings with the Test button. A sample sound is sent to the external editor.

Run which external editor
The "Run which external sound editor" box specifies how Springboard should find the external
editor. Most sound editors register themselves with Windows as the default editor for the file
types they support. Windows has two built-in ways an application can register itself to handle a
given file type: Open and Edit. These work the same, but typically the Open verb is used for
applications that are mainly quick viewers, and Edit is used by applications that can modify a
file.
So, normally, your external sound editor should register itself with Windows under the Edit verb,
and Springboard will work correctly without any changes in this dialog box.
If it does not work correctly - if you get an error message, or if the sound loads in the wrong
program - you can try the other verb (Open vs. Edit), or you can choose "With this command
line:" and click the button at the right of the edit box to browse for the program you want to run.
This should work with most sound editors; unusual ones may also require extra symbols on this
line called "command line arguments." This information should be provided in the documentation
for your external program.
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Preferences - Display tab

The Display tab of the Preferences dialog sets options relating to the overall display of
storyboards.
Check the "Use smooth resizing..." check box to get a smoother appearance when the storyboard
grid is zoomed in closer than 100% using the View > Zoom commands. This can slow down
your computer, so leave it unchecked if your computer seems too slow while zoomed in.
The "Font for frame text" box lets you choose the font and point size used for text in the Frame
Text box. The Sample box shows what the text will look like.
This font is also used for printing, by default, but can be overridden in the Fonts tab of the Print
dialog.
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Preferences - Units tab

The Units tab of the Preferences dialog sets the units you wish to use throughout Springboard.
These units are used to display values in the Page tab of the Print dialog.
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Preferences - Camera tab

The Camera tab of the Preferences dialog controls Automatic Zoom.
The Animate... check box turns Automatic Zoom on or off globally.
The Follow... drop-down box below it lets you change the name of the layer whose Zoom Frame
vectors should be used for Automatic Zoom. For example, if you use a layer called "Kamera"
instead of "Camera," type "Kamera" in this box to activate Automatic Zoom for that layer.
(It's probably easiest to use a global layer as the c amera layer, but it's not required. Only global
layers are listed in the drop-down list, but you can type any name you like.)
The Enable... check box setting determines whether newly-created frames have their Animate
camera check box set in Frame Properties - that is, whether Automatic Zoom is enabled for
individual new frames. This is set by default.
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Story Properties
The Story Properties dialog shows the properties that apply to the entire story.

To view Story Properties:
1. If the Story Tree is not already visible, do View > Story Tree/Properties View.
2. Click on the top element in the story tree, with the open book icon

.

The Story Properties dialog then appears below the Story Tree.

The Story Properties dialog contains:



The story's title. This is the name of the file by default, but you can change it. The title is
used by the default HTML export templates and is also used by default in printing.



The story's frame rate. This is the number of frames per second used when exporting to AVI
(video). It also determines how times are displayed in the Frame Properties dialog and in the
Movie View.



The story's duration. This is the total length of time contained by all the story's contents.



The default frame size for new frames. This is the width and height, in pixels, of new
frames created with Edit > Add New Frame. (The size of an individual frame can also be
changed after they're created with Change Image Size or Change Canvas Size.)

The Match current button sets the default frame size to match the current frame.
The "..." button next to Match current opens the Custom Size Dialog so you can enter a
frame size that doesn't appear in the list.
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Frame Properties
The Frame Properties dialog shows the properties that apply to an individual frame of the
storyboard.

To view Frame Properties:
1. If the Story Tree is not already visible, do View > Story Tree/Properties View.
2. Select the frame whose properties you want to view. You can select the frame in the story
grid, with the Go menu commands, or by clicking its node in the Story Tree.
The Frame Properties dialog then appears below the Story Tree.

The Frame Properties dialog contains:



The frame's Title. This appears in the Story Tree to help identify the clip. You can also
optionally include with the frame number when printing storyboards.



The frame's Start time. This is the duration of all the preceding frames.



The frame's Duration - how long it will last on screen, including any Overlap.



The duration of the Overlap between this frame and the next frame.



The frame's End time. This is the time at which the frame has completely passed, including
any Overlap.



The Animate camera check box, which controls camera animation for this frame. If this box
is checked, Automatic Zoom is performed for Zoom Frame vectors within this frame's camera
frame (as set in the Preferences dialog - Camera tab).

All times are shown in time controls.

To change a frame's duration:
Do one of the following:



Change the Duration value to the desired duration.



Change the End time to the time point at which you'd like the frame to end.



Record the duration interactively in the Movie View.

Frame durations default to 3 seconds per frame.
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Overlapping transitions
To indicate a transition between two frames other than a straight cut, set the Overlap property of
the first frame. The following frame will then start fading in before the current frame ends. If
there is no following frame, the Overlap is the length of the fade-to-black applied to the end of
this frame.
You can set the Overlap duration manually, by editing the Overlap control, or you can record
transitions interactively in the Movie View.
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Zoom Frame Properties
The Zoom Frame Properties shows the properties of the currently-selected Zoom Frame vector:

This dialog is shown automatically when a Zoom Frame vector layer is selected.

Reverse direction
Checking or clearing the Reverse direction check box reverses the direction of the zoom
arrows. This is described in more detail under The Zoom Frame tool.
Double-clicking in the frame has the same effect as clicking the Reverse direction box.

Animation timing
The Start, Duration, and End time controls determine when the Zoom Frame will be animated,
if Automatic Zoom is enabled. The Start and End times are story times (relative to the
beginning of the story). Setting the Duration changes the End time, and vice versa.
By default, the Auto check boxes are set for both Start and Duration/End. This means that the
timing for this Zoom Frame is set automatically: it starts animating at the beginning of the
frame and animates to the end of the fram e. If there are multiple Zoom Frames in the frame, the
frame duration is divided evenly among them.
Changing the Start, Duration, or End time clears the corresponding Auto check box, and "pins
down" or "fixes" the corresponding time. A Zoom Frame with a fixed Start time looks like this:

Automatic times adjust when new Zoom Frames are added to the frame; fixed times do not.
Fixed times are adjusted, however, if the frame that contains the Zoom Frame is moved in time e.g., if additional frames are inserted or deleted before it.
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Checking the Auto box resets the corresponding time to its automatic value.

Ease
The Ease property controls how the Zoom Frame animates between its "from" rectangle and its
"to" rectangle. The possible values and their meanings are:



In And Out: The animation starts and ends slowly, and moves more quickly in the middle.
This is the default for new Zoom Frames.



Ease In: The animation starts slowly, speeds up, and stops abruptly.



Ease Out: The animation starts abruptly, then slows down at the end.



None: The animation starts and stops abruptly, and moves at a constant speed. This is the
default for Zoom Frames that were created in Springboard version 0.70 and before.

In general, In And Out is most useful when you have a single Zoom Frame in a frame, because
it gives a clear start and end to the camera move. If you have a continuous sequence of Zoom
Frames, you may want to use Ease In on the first and Ease Out on the last, and None on the
rest (if there are more than two). You may also use None if you want an abrupt effect; for
instance, to insert a reaction shot during a continuous pan.
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Sound Clip Properties
The Sound Clip Properties dialog shows the properties that apply to the currently-selected sound
c lip. See also Working with sound.

To view Sound Clip Properties:
1. If the Story Tree is not already visible, do View > Story Tree/Properties View.
2. In the Story Tree, click the sound clip whose properties you want to view.
The Sound Clip Properties dialog then appears below the Story Tree.

The Sound Clip Properties dialog contains:



The clip's Title. This appears in the Story Tree to help identify the clip.



The clip's Offset. This is added to the Start time of the story element that contains the sound
clip to determine the clip's Start time. You can edit this to start a sound clip later than its
parent story element.



The clip's Start time. This is the time from the start of the story when the sound will start
playing.



The clip's Duration - how long it will play. Clips will continue to play if they overlap into
subsequent frames. They will stop playing, however, at the end of the last frame of the file
(even if their Duration extends further).



A Volume slider. Drag this slider to the left to make the clip quieter, and right to make it
louder. The default volume (10) means to leave the sound as it was imported or recorded,
with no change in volume. While you hold the mouse down, the clip plays, along with other
clips that are at the same time in the story.



A Mute check box. Checking this box will silence a clip - it will produce no sound, either in
the Movie View or in export. This is not an animatable control, and it silences the clip no
matter what the Volume setting is.



A Play button. Clicking this button plays the sound clip once, by itself. If you hold it down
until the sound has finished, the sound will loop until you click the button again.

All times are shown in time controls.
If the sound clip is stored in a split file, and the split file is damaged or missing, the Duration
edit box will be pink, and it will contain a message describing the problem.
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To adjust the time when a sound plays:
Do one of the following:



Move it to an earlier or later parent element.



Change the Offset to a larger value, to start it later in time.

Negative Offsets will be supported in a future version of Springboard.
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Time Controls
In various places in Springboard, time is expressed in time controls. They look like this:

If a time control is unchangeable - for display only - it is grayed out, like this:

Time format
Time is always expressed in digit groups like this:
hours : minutes : seconds : frames
The frames number uses the story's frame rate setting, which you can change in the Story
Properties dialog.

Editing in time controls
You can change the value of a time control in a number of ways:



You can select the contents of the control and type over it, like other text controls. Some
examples of how the value you enter will be interpreted:
12

12 frames

12.

12 seconds

12.5

12.5 seconds

12:5

12 seconds + 5 frames

12:

12 seconds

12:0:0

12 minutes

12::

12 minutes



To select a digit group, double-click it. To select the entire value, triple-click.



Click the up and down arrows at the right of the control to increase or decrease the digit
group at the left of the selection, or at the cursor.



Press the Up and Down arrow keys to increase or decrease the current digit group.



If the entire text is selected, the up/down buttons and keys affect the seconds.
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Set Background Color
Use the Image > Set Background Color command to bring up the Set Background Color
dialog.
Use this dialog to change the color that appears below all other layers (it's white by default).
For convenience when you want to draw in white on black, select the "Invert..." check box to
invert any black or white spot-color layers in the affected frames.
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Mirror Frames
Use the Image > Mirror Horizontally command to bring up the Mirror Frames dialog.
Use this dialog to reverse a single image or a range of images left-to-right, as it would look in a
mirror. This can help you explore different options for frame composition and sequencing.
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Change Image Size
Use the Image > Image Size command to bring up the Change Image Size dialog.
This dialog lets you enlarge or reduce a frame or a group of frames. The image contents are
resized as well.
To leave the image contents the same size while you change the frame size, use Image >
Canvas Size instead.
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Change Canvas Size
Use the Image > Canvas Size command to bring up the Change Canvas Size dialog.
This dialog lets you enlarge or reduce the drawing area for a particular frame without changing
the size of what you've already drawn. You can fasten down a corner of the existing image with
the Anchor buttons, and the new space will be added on the sides opposite the anchor.
To squash or stretch the image contents while you change the frame size, use Image > Image
Size instead.
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Index
-AAdd New Frame 71
Animating the camera 25
Automatic Zoom 28

-BBake Layer Position 72

-CChange Canvas Size 133
Change Image Size 132
Clear Undo Information 73
Convert Layer 74
Copyright and legal information 6
Customizing Springboard 37

-DDeflate Layer To Fit Content 75
Drawing layers: Overview 8
Duplicate Layer 76

-EEdit Layer Externally 77
Edit Sound Externally 78
Export Again 114
Export HTML 111
Export To 113, 79
Export Windows AVI 109

-FFill layers 21
Finish Editing Layer Externally 80
Frame Animation View 61
Frame Properties 123
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-IImport Image 81
Import Sound 83
Inflate Layer To Fit Frame 84
Introduction 5

-KKeyboard shortcuts 38

-LLayer colors 19
Layer Opacity 46
Local and global layers 12
Lock Frame Position 85

-MMake Fill Layer 87
Matte In Layer Transparency 88
Menu index 67
Merge Contained Layers 89
Merge Layer Down 90
Mirror Frames 131
Mouse & pen shortcuts 41
Move File 91
Movie View 64

-NNatural-media tools 48
Nested layers 15

-PPlay Movie 93
Preferences - Camera tab 121
Preferences - Display tab 119
Preferences - Edit Images tab 116
Preferences - Edit Sounds tab 118
Preferences - Units tab 120
Preferences Dialog 115
Print 92
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-QQuick Start 7

-RRecording 64
Reset Layer Position 94
Reset Layer Transparency 95

-SSave Numbered Backup 96
Scale Layer To Fit Frame 97
Scroll Current Frame 98
Set Background Color 130
Single Frame View 60
Sound Clip Properties 127
sound clips 64
Split And Edit 100
Split Every 101
Split Out/Unify 102
Story Properties 122
Storyboard View 59

-TThe Arrow tool 54
The Edit Vector tool 47
The Ellipse tools 53
The Layers Palette 10
The Line tool 50
The Move Layer tool 43
The Rectangle tools 52
The Solid and Outlined Arrow tools 55
The Story Tree 24
The Text tool 51
The Tools Palette 42
The Zoom Frame tool 56
Time Controls 129

-UUndo and Redo 103
Unify Every 104
Using an external graphics editor 30
Using an external sound editor 33
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-VVector tools 49
View Frame Animation 105
View Movie View 106
View Single Frame 107
View Story Tree/Properties View 108

-WWorking with large files 34
Working with sound 31
Working with split files 35

-ZZoom Frame Properties 125
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